Windows 7 Login failed for user “IIS APPPOOLDefaultAppPool”

While starting development on a new project in Windows 7, I ran across the following error when trying to access the database.

Cannot open database "<Database Name>" requested by the login. The login failed.
Login failed for user 'IIS APPPOOLDefaultAppPool'.

 

I initially Googled the error and found this forum post that helped me solve the problem.  The site is in some other language so I will go over what you need to do here.

First, find the site that your application running under in IIS.

Select the site and click on “Advanced Settings” in the column on the right.  See which Application Pool your site is running under.

Now, click on “Application Pools” in IIS and select the application pool that your site is running under.  Click on “Advanced Settings”.

Scroll down to the “Process Model” section and click on the identity field.  Once it is selected, click on the “ellipsis” button.  In the dropdown under “Built-in Account” select “LocalSystem”.

Advertisements
Windows 7 Login failed for user “IIS APPPOOLDefaultAppPool”

10 thoughts on “Windows 7 Login failed for user “IIS APPPOOLDefaultAppPool”

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s